Excel-Funktion: SUMMENPRODUKT

Eine in Excel recht unbekannte aber sehr mächtige Funktion ist SUMMENPRODUKT. Damit lassen sich Berechnungen zum Teil erheblich vereinfachen. Außerdem können Sie mit SUMMENPRODUKT bedingte Berechnungen durchführen. Los geht´s!




Wie funktioniert SUMMENPRODUKT?

Die Funktion SUMMENPRODUKT tut das was der Name schon sagt. Es werden Zahlen multipliziert und die Ergebnisse addiert. Zunächst ein einfaches Beispiel. Aus einer Produktliste soll der Gesamtpreis ermittelt werden. Klassischerweise werden zuerst die Einzelpreise ermittelt (multipliziert) und dann die Summe daraus ermittelt.



Mit SUMMENPRODUKT sparen Sie sich die Berechnung der Einzelprodukte. So gehen Sie vor.

Starten Sie die Funktion über den Funktionsassistenten (fx). Dann wählen Sie bei Array1 die Preis-Spalte aus, danach in Array2 die Anzahl-Spalte.

 


Das Programm berechnet nun zuerst für jede Zeile das Produkt aus den Werten der beiden Spalten. Das Endergebnis besteht schließlich aus der Summe dieser Einzelwerte.
Wichtig: Die Arrays müssen dieselbe Dimension haben. Also gleich viele Spalten wie Zeilen.


SUMMENPRODUKT mit Matrizen höherer Dimensionen

Die Funktion des Summenprodukts kann nicht nur für einfache Listen zum Einsatz kommen, sondern auch für zweidimensionale Matrizen. Hier ein Beispiel:

 


Die Funktionsweise ist gleich wie im ersten Beispiel. Hier wird ebenfalls als Erstes der Wert jeder Zelle des Bereichs 1 mit dem Wert der entsprechenden Zelle des Bereichs 2 multipliziert. Das Endergebnis besteht aus der Summe der errechneten Produkte. Die Verwendung dieser Formel ist identisch mit der bei den einfachen Listen. 


Bedingte Berechnungen mit SUMMENPRODUKT

Seine ganze Kraft zeigt SUMMENPRODUKT in der Auswertung von Wahrheitswerten und damit im Berechnen einer bedingten Summe. Sehen Sie folgendes Beispiel.
Aus der Mitarbeiterliste sollen die Gehälter aller Personen aus der Abteilung LA ermittelt werden.

 


Dazu multiplizieren Sie die Spalte ABT mit der Spalte GEHALT. Um nun die Bedingung zu formulieren, dass nur die Zeilen berechnet werden in denen LA steht, muss die Eingabe in Array 1 so aussehen: (C2:C26=“LA“)*1. Die Multiplikation mit 1 ist deshalb erforderlich, damit keine Wahrheitswerte (WAHR, FALSCH) sondern Zahlen (0,1) ausgegeben werden. *1 macht also aus den Wahrheitswerten WAHR und FALSCH 0 und 1.

Mit dieser Methode können Sie mit SUMMENPRODUKT sehr komplexe, bedingte Berechnungen durchführen. SUMMENPRODUKT lässt bis zu 255 Arrays zu.

Im letzten Beispiel soll mit SUMMENPRODUKT errechnet werden, wie viele Seminartage in Stuttgart im Programm Excel geschult wurden. So sieht die Funktion in der Bearbeitungszeile aus:

=SUMMENPRODUKT(--(Tabelle1!$B$2:$B$512="Stuttgart");--(Tabelle1!$D$2:$D$512="Excel"); Tabelle1!$G$2:$G$512)

Hinweis: Statt eine Bedingung mit 1 zu multiplizieren (wie im Beispiel oben), kann stattdessen vor die Klammer ein Doppelminus „- -“ gestellt werden.

 







Bild: © Sergey Nivens - shutterstock.com 
Freelancer Profil kostenlos anlegen. Aktuelle Projekte erhalten!

 Jetzt durchstarten

Weitere Artikel

Kommentare

  • Keine Kommentare vorhanden

Artikel kommentieren